Help
lexigame.com the home of unique word games

Lexigame Community
June 21, 2019, 04:26:20 AM *
Welcome, Guest. Please login or register.

Login with email, password and session length
News:
 
   Home   Help Search Calendar Login Register  
Pages: [1]
  Print  
Author Topic: bitninja security message  (Read 474 times)
mkenuk
Glossologian
**
Posts: 1788


Life? Don't talk to me about life.


View Profile
« on: February 10, 2019, 12:15:36 PM »

This is a test message.
Everything seems to be back to normal.
I can access both sites, and they both have a working forum.

I'm not sure what you have done - I certainly did nothing - but thanks anyway.

Mike

ps Since this message will be quite meaningless to anyone else, feel free to delete it.

« Last Edit: February 10, 2019, 12:19:31 PM by mkenuk » Logged
Alan W
Administrator
Eulexic
*****
Posts: 3691


Melbourne, Australia


View Profile Email
« Reply #1 on: February 10, 2019, 02:11:48 PM »

Mike, I did nothing either!

Just one of those mysterious gremlins that comes and goes.

(As you may have gathered, Mike was having problems getting to the forum.)
Logged

Alan Walker
Creator of Lexigame websites
mkenuk
Glossologian
**
Posts: 1788


Life? Don't talk to me about life.


View Profile
« Reply #2 on: February 10, 2019, 06:05:01 PM »

Perhaps a few details wouldn't go amiss in case something similar happens to them.

Playing the 10-letter game yesterday afternoon (local time) in the chi.lexigame.com site, I noticed that the Forum section of the page had been replaced by a warning from 'Bitninja.co.io' (or something like that). I clicked on the 'Full Page' button to return to the normal screen and I saw that that was the same.
I returned to the 'Full Screen' mode and found that the game had disappeared completely to be replaced by 'bitninja'

Using the icon on my 'favourites' bar, I was able to get back to Chi on the chihuahua-puzzle.com site. This was working normally but there was no forum.

At this point I e-mailed Alan; I'd assumed, wrongly, that the Chi site was infected by a virus of some kind. Alan replied to my email assuring me that there was nothing wrong with the site, that everything was running normally. He suggested that I reload chi.lexigame.com. but I was unable to do that.

I did all the usual things to my computer - system restore and a quick McAfee virus scan, which reported no problem

Later that night I played the Challenge game with chihuahua-puzzle.com. I was still unable to open chi.lexigame.com (Bing actually informed me that there was no such website!)

I played the new standard game; logged off and on a hunch about 30 minutes later opened the site again to find that everything was back to normal - both websites, complete with forum, were up and running - certainly not because of anything I had done, and, Alan assures me, not because of anything he had done.

Perhaps some forumite who speaks Computerese knows what happened -  I sure as hell don't.
Logged
blackrockrose
Lexicomane
***
Posts: 121


Muswellbrook, Australia


View Profile WWW
« Reply #3 on: February 10, 2019, 07:47:15 PM »

Mike, I experienced the same bitninja problem several days ago.

I had changed my password to access the site on the previous day, because I suddenly found myself logged out and (rather stupidly) had not made a note of my existing password, so had to reset it.

I thought that this new password was the reason this bitninja character was having a problem with me (especially since I knew that Alan had recently had to switch to a different hosting platform).

Anyway, I was able to log in for the rest of that day using the alternative url, without any interference from bitninja, and the next day everything was back to normal at chi.lexigame.com.

Weird.
Logged
Alan W
Administrator
Eulexic
*****
Posts: 3691


Melbourne, Australia


View Profile Email
« Reply #4 on: February 11, 2019, 12:45:57 PM »

This has just happened to me!

The security messages I saw asked me to go through a "reCaptcha" process. (I am not a robot... Click on all the images with cars, etc.) But this didn't fix things up immediately. I kept getting the messages for a while. Now it looks like things are back to normal, but for how long?

It seems that this bitninja crowd sell their services to web hosting companies, so it is possible that the service is installed on the new server that lexigame moved to at the start of the month. I've written to the hosting service asking if they use bitninja, and telling them that, if so, it's causing problems.

The idea, I think, is to protect web sites from malicious types who flood the site with automated queries, but it seems to be overreacting to normal patterns of web usage.
Logged

Alan Walker
Creator of Lexigame websites
Alan W
Administrator
Eulexic
*****
Posts: 3691


Melbourne, Australia


View Profile Email
« Reply #5 on: February 11, 2019, 03:35:36 PM »

UPDATE:

Yes, bitninja is a service used by the hosting company that runs the server where lexigame lives. They told me it was nothing to worry about - just answer the Captcha and you will be able to access your website. I wrote back pointing out that the issue isn't how easy it is for me to access the website - it's supposed to be easy for anyone to access the website.

If this bitninja system is capable of working well, it is obviously not configured properly on this server. I've asked the hosting company to investigate.

In the meantime, if you see something like the image below when you try to visit the forum or Chihuahua, don't get alarmed. The logo might look like that of a cyber criminal gang, but it's actually a genuine cyber security firm.



* bitninja-message.png (40.02 KB, 795x769 - viewed 121 times.)
« Last Edit: February 11, 2019, 03:39:10 PM by Alan W » Logged

Alan Walker
Creator of Lexigame websites
mkenuk
Glossologian
**
Posts: 1788


Life? Don't talk to me about life.


View Profile
« Reply #6 on: February 11, 2019, 05:26:49 PM »

Touch wood, I have had no further messages from bitninja and everything seems to be working normally.
I reckon it was 'with me' (if I can put it like that) for about 15 hours, from first spotting the thing on the forum to getting back to the situation where  both Chi sites were working normally.

A few years ago a pop-up message at the bottom right-hand corner of the screen which claimed to come from the virus scan I was using at that time suggested that I run a program that it was offering that would 'overhaul' my computer.
I made the mistake of clicking on it. Very big mistake. Long story short, it needed a professional programmer to come and sort out the mess it made of my registry.
Since then my policy has been always to delete at once anything which appears on my screen uninvited.
Bitninja didn't give me the chance to do that. By the time I'd located the red x to close it, it had expanded to full screen size.
It doesn't seem to have done any harm, but I've no desire to see it again
Logged
Alan W
Administrator
Eulexic
*****
Posts: 3691


Melbourne, Australia


View Profile Email
« Reply #7 on: February 13, 2019, 08:13:27 PM »

Has anybody else had a security message like the one in my previous post? I'm interested to know how widespread a problem this is. (If you're reading this and you're not a forum member, you could drop me an email at info@lexigame.com.)
Logged

Alan Walker
Creator of Lexigame websites
anonsi
Glossologian
**
Posts: 1968


Iowa, US


View Profile
« Reply #8 on: February 14, 2019, 01:28:05 AM »

I haven't seen it.
Logged
Ozzyjack
Glossologian
**
Posts: 1035


Southern Highlands, NSW.


View Profile
« Reply #9 on: February 14, 2019, 04:18:47 AM »

Has anybody else had a security message like the one in my previous post? I'm interested to know how widespread a problem this is. (If you're reading this and you're not a forum member, you could drop me an email at info@lexigame.com.)

Hi Alan,

When I opened up Chihuahua on my laptop about half an hour ago, I was confronted by the security message.  Apparently I had a system upgrade earlier this morning and the system had rebooted itself.

I went through the capcha procedure and the screen appeared to freeze.  I went away and when I came back 10 minutes later I reloaded chihuahua  and now everything is working fine.
Logged

Cheers, Jack


We must believe that we are gifted for something, and that this thing, at whatever cost, must be attained. –Marie Curie
Pages: [1]
  Print  
 
Jump to:  

Powered by MySQL Powered by PHP Powered by SMF 1.1.21 | SMF © 2006, Simple Machines Valid XHTML 1.0! Valid CSS!
Page created in 0.029 seconds with 19 queries.